Skocz do zawartości
Cygnus

Game Maker Studio problem z tłami

Rekomendowane odpowiedzi

Cześć wszystkim,czy ktoś może mi pomóc? ale na poważnie

Niżej screen z problemem.Otóż jak ustawie drugie tło jakiekolwiek,to widać łączenie tak jakby kreskę długą poziomą:/

Jak się tego pozbyć?

I jeszcze druga sprawa ustawiam w roomie,żeby tło się poruszało,fakt porusza się,ale ucieka:/ a chcę żeby się poruszało tło główne,ale nie uciekało.

Na czerwono zaznaczyłem tą denerwującą linie,której chcę się wyzbyć..a przeszkadza.

problem.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Może pomyliłeś się o 1px. i nadłożyło lub 1px. prześwitu , prześlij zrzut podglądowy ustawień tła to może się trochę problem rozjaśni .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

mi takie coś sie działo jak miałem bardzo duzy obrazek, zobacz w kosooli czy ci backgrounda nie konwertowało

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Kurcze chłopaki,a jak to sprawdzić:/ tło główne mam w rozdzielczości 1920x1080 a te drugie mniejsze to 1920x468

Jak ten zrzut zrobić?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

No to faktycznie duża rozdzielczość , w starej wersji GMS , był taki błąd . Ale teraz nie powinno być problemów , co do zrzutu - prześlij kod którym ustawiłeś tło lub z menu (rooms-room-backgrounds)

 

i tło które jest wyświetlane niżej , prawdopodobnie Background 1.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Texture page jest mniejsze niż ta grafika. Stąd ten problem (skalowanie).

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A spróbuj może w Global Game Setings w zakładce Windows i tam w bocznej zakładce Graphics wyłączyć funkcje "Interpolate colors between pixels". Wtedy nie będzie ci wygładzać pikseli i może zniknie ta linia.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie no, ta linia jest dla tego, ze przeskalowało teksturę i wysokość się zaokrągla.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pisałem tego posta wtedy kiedy ty Gnysek swojego tylko go minute wcześniej wysłałeś :D Nie twierdze ,że nie masz racji.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Chłopaki linia zniknęła jak odznaczyłem Interpolate colors between pixels,za to dziękuje;) ale teraz te tekstury nie są wygładzone..i średnio to wygląda...:/

Gnysek widzę,że wiesz jak ten problem rozwiązać.Mam dwa tła jedno główne pierwsze 1920X1080 a drugie mniejsze 1920x468.Wersje mam najnowszą 1.3 w nie których wersjach miałem z tym problem potem go nie było,a teraz w tej nowej znowu.Jestem zielony w tym:/ a potrzebuje pomocy z wytłumaczeniem co i jak.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Chodzi oto że grafiki są umieszczane na takich specjalnych teksturach w pamięci i ona jest zbyt mała by zmieściła się na niej grafika twojego tła. Więc musiała zostać zmniejszona a potem przy wyświetlaniu jej znowu powiększona do odpowiednich rozmiarów w efekcie powstały artefakty.

Jak nie to niech Gnysek mnie poprawi.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Albo potnij grafiki na mniejsze, albo zwiększ rozmiar texture pages na 2048. Chociaż nie zalecam. Ogólnie grafiki nie powinny przekraczać 1024px.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W Global Game Settings (zakładka Windows ???) zwiększ texture pages na jak największy i powiedź czy jest ok. Jak nie to będziesz musiał zmniejszyć dwukrotnie background i w kodzie go sobie skalować żeby było fajnie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Słuchajcie ustawiłem w zakładce W Global Game Settings-Windows tekstury na 2024x2024,ale nic to nie daje,dalej ta pieprzona kreska:/

Co pozostaje mi teraz chłopaki? napiszcie co mam zrobić żeby to dobrze działało,może jakiś kod? co i gdzie wpisać:/ ech.Jedynie znika jak odznaczę interpolate colors between pixels,ale wtedy nie wygładza tych tekstur i gorzej grafika wygląda:/

Proszę pomóżcie...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Chłopaki,to co mam teraz zrobić?

 

Rozumiem,że dwa razy mniejszyć rozmiar grafiki tak z 1920x1080 na 960X540 i drugie tło z 1920x468 na 960x234 tak? i ten kod żeby skalować,ale jak ,gdzie to wpisać,proszę wyjaśnijcie mi to krok po kroku.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Możliwe, że masz złe proporcje rozdzielczości. Sprawdź.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Clamping.

 

Zawsze ten cholerny clamping..

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czy,ktoś mi z tym problemem pomoże?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Albo potnij grafiki na mniejsze, albo zwiększ rozmiar texture pages na 2048. Chociaż nie zalecam. Ogólnie grafiki nie powinny przekraczać 1024px.

Słuchajcie ustawiłem w zakładce W Global Game Settings-Windows tekstury na 2024x2024,ale nic to nie daje,dalej ta pieprzona kreska:/

Czy,ktoś mi z tym problemem pomoże?

Po pierwsze, gnysek napisał 2048, a nie 2024. Po drugie, powiedz nam jakich rozmiarów jest twoja grafika tła. :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jak wogóle patrze na tego screena to on jest lekko rozciągnięty choć może mi sie wydawać.

Korzystasz z viewów ? No bo może ustawiłeś view in room na 500x500 a port on screen na jakieś 1280x1024 i ci się obraz rozciągnął i ta linia pojawiła.

Bo ogólnie jak masz view in room na 500x500 to port on screen musi mieć np. 1000x1000 bo 500x2 albo 250x250 bo 500/2 a nie może mieć 254x254 bo to sie ani nie mnoży ani nie dzieli.

Spróbuj.

 

Jakbyś dał link do projektu to projektu byłoby łatwiej wyłapać błąd ,zamiast zgadywania co może być przyczyną bo przyczyn mogą być dziesiątki.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Tak Korzystam z View,ze względu na to,że lepiej się wtedy gra prezentuje.Pokoje wszystkie mam na 1920X1080,a view in room usttawione wszedzie na 960x540,a port on screen na 1920x1080 no i nic to nie daje..Dalej kreski są.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sami zobaczcie o to ustawienie room zakładka views

 

hhh.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

No przy takim skalowaniu to się niestety może zdarzyć. Powinieneś wyłączyć automatyczne rysowanie application_surface, a potem w evencie post draw któregoś z obiektów (jednego!) dać draw_surface_ext(0,0,application_surface,1920,1080); i gra będzie ładnie rozciągnięta.

 

Polecam: http://yoyogames.com/tech_blog/45 oraz manual

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Dziękuje Gnysek

A powiedz mi,w którym miejscu mam wyłączyć application_surface?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A,więc tak Gnysku;)

 

Stworzyłem pusty obiekt o nazwie obj_skalowalnie

 

i w nim tak w ewenencie Create wpisałem:

 

GML
[/gml]

application_surface_enable(true);

application_surface_draw_enable(false);

[gml]

 

a w ewenencie Post Draw wpisałem:

GML
[/gml]

draw_surface_ext(0,0,application_surface,1920,1080);

[gml]

 

No,ale błąd wyskakuje w ewenencie Post Draw "Wrong number of arguments to function on script

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

No to chyba wiadomo w czym jest błąd :) Pomyliłem nazwę funkcji, ta powyżej faktycznie przyjmuje więcej parametrów, ale trzeba podać skalowanie, a ja chciałem wys/szerokość.

Chodziło oczywiście o:

 

GML
draw_surface_stretched(application_surface, 0, 0, 1920, 1080);

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Gnysku no cóż zrobiłem tak jak Ty,hmmm błędu nie ma gra się odpala,ale dalej jest linia,oczywiście objekt ten umieściłem na planszach.Jedynie co to się ekran zmniejszył,a kreska jak jest tak jest:/

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Być może to inny problem , spróbuj wyłączyć z wyświetlania te zielone pagórki . Jeśli problem ustąpi to wina tego tła z górkami , Ponieważ z tych screenów które przesłałeś w żaden sposób rozdzielczości tła n ie zgadzają się z tymi wymiarami , tak samo jak ten pasek .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Aaaa, a może one są jako backgroundy, ale włączone jest skalowanie ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.

Zaloguj się tutaj

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×