Skocz do zawartości

Ice Cube

Użytkownicy
  • Postów

    208
  • Rejestracja

  • Ostatnia wizyta

  • Wygrane w rankingu

    2

Ostatnia wygrana Ice Cube w dniu 15 Marca

Użytkownicy przyznają Ice Cube punkty reputacji!

O Ice Cube

  • Urodziny 01.01.1970

Informacje

  • Team
    kwadrat

O mnie

  • Skąd
    Kato
  • Płeć
    Male

Ostatnie wizyty

2177 wyświetleń profilu

Ice Cube Osiągnięcia

Major User

Major User (5/13)

2

Reputacja

  1. Najwięcej mogę dać 255 . gm8- kończę projekt na tej wersji, następne będą juz na najnowszej.
  2. Game maker 8.0 tak mówimy o show message w grze używam 3-ech trzcionek, ale jakieś sciągnięte z internetu, nie microsoftowe. ta która robi błędy ma ustawienia: character range 32 till 255
  3. Może to być wina czcionki , która tylko ja mam na komputerze zainstalowaną ?
  4. Mój komputer ma windows 10 polska wersja 1 znajomy ma komputer z windowsem 10 polska wersja 2 znajomy ma komputer win 10 english version i tylko u mnie pokazuje dobrze pl znaki ąęćśń itp
  5. Hej! Dlaczego w show_message gdy używam polskich znaków to na jednym komputerze działają i widać je dobrze a na innym komputerze zamiast polskich znaków są wyświetlane jakieś dziwne znaki ? pozdro
  6. Właśnie niestety gm8, ale muszę w nim skonczyć projekt, bo konwersja na gm2 nie wchodzi w grę. Muszę znaleźc złoty środek, by gra działała na słabych i mocnych kompach, tak by fps był w granicach 15-30. Czytałem coś o delta time, ale nie wiem jak to ugryźć. Dawno dawno temu jak programowałem w assemblerze aby spowolnić program stosowało sie pętele opóźniające z instrukcją NOP . ale muszę mieć jakiś odnośnik czasowy do danego komputera na którym gra będzie odpalana. Myślę nad czymś takim by : 1.sprawdzić jak szybki jest dany komputer 2.jeżeli za szybki to spowolnic odpowiednio do 30 fps stosując w kodzie coś co będzie odpowiednio zamulac kompa. 3.jeżeli za wolny to poprostu wyświetlic napis, że procek nie daje rady
  7. Hej Gdy odpaliłem moja grę na kompie u kolegi z 15 fps nagle wskoczyło do 60 fps!!, w grę nie dało sie grać.. wszystko działało za szybko. Na moim kompie max fps to 15 i tak gra sie dobrze. jak to ograniczyć? , czy wystarczy w roomie wpisać speed =15 i wtedy wszędzie na szybkich kompach będzie te 15 ? czy idzie dać obiekt z kodem co będzie pilnować prędkości gry, by nie przekroczyła danego progu? pozdro
  8. bloki: //1 d3d_draw_wall(1880,1310,80,1940,1310,0,background_get_texture(blok1),1,1); d3d_draw_wall(1940,1310,80,1940,1410,0,background_get_texture(blok1),1,1); d3d_draw_wall(1940,1410,80,1880,1410,0,background_get_texture(blok1),1,1); d3d_draw_wall(1880,1410,80,1880,1310,0,background_get_texture(blok1),1,1); //2 d3d_draw_wall(1990,1420,106,2190,1420,0,background_get_texture(blok2),1,1); d3d_draw_wall(2190,1420,106,2190,1580,0,background_get_texture(blok2),1,1); d3d_draw_wall(2190,1580,106,1990,1580,0,background_get_texture(blok2),1,1); d3d_draw_wall(1990,1580,106,1990,1420,0,background_get_texture(blok2),1,1); itd.. player/camera: DRAW: d3d_set_projection( x, y, z, x + global.camcos, y + global.camsin, z + global.campitch, 0, 0, 1); grafiki nie umiem dodać ,pisze ze max grafiki to 808 b mb , a plik ma 46 kb..
  9. niestety przesunięcia nic nie dają
  10. W gierce 3d mam sporo budynków różnej wielkości i pod różnym kątem porozrzucanych po planszy. gdy jestem blisko jakiegokolwiek budynku to wygląda on dobrze, natomiast jeżeli sie oddale od niego dosyć daleko to jego boki migotają, nakłądaja sie na siebie textury scian. bloki sa zbudowane z 4x d3d_draw_wall textury starałem się by miały wymiary 256x256 lub 256x128 pix. Idzie to jakoś poprawić ?
  11. Chciałbym aby w ciągu 60 sekund jeden obiekt pojawił się, a drugi zniknął przy uzyciu alpha, oczywiście uwzjgędniając w obliczeniu by nie dzielic przez zero. Drugi obiekt jakos nie działa.. nie mam pomysłu na niego sekunda+=1 if sekunda>59 end draw_set_alpha(sekunda*0.016666) draw obj1 draw_set_alpha(1/sekunda) draw_obj2
  12. Właśnie w tym problem, ze dzwięki to prawdziwe wavy. Odkąd zacząłem stosować odtwarzanie dzwięków z zastosowaniem sound_add(),które po odtworzeniu są gumowane sound_delete() niektóre nie grają.. i to jest jakby losowo, gdy podopisuje coś w kodzie... Zastanawiałem się, czy komputer nie potrzebuje więcej czasu na wyczyszczenie dzwieku z ramu jakąs komendą typu (nic nie rób przez jeden takt) ewentualnie czy moja karta muzyczna nie wyrabia..
  13. Cześć Możecie mi wytłumaczyc różnice miedzy sound_delete v$ sound_discard ? gdzie i co stosować ?
  14. Pojawił sie pewien problem z sound_delete ,poniewaz nie odtwarza niektórych dżwieków. przykladowy kod: wiadomosc=choose(0,1,2,3,4,5,6,7,8,9) if wiadomosc=0 { m=sound_add(working_directory+"\gra\1.wav",0,0) sound_play(m) show_message("1") sound_stop(m) sound_delete(m)} if wiadomosc=1 { m=sound_add(working_directory+"\gra\2.wav",0,0) sound_play(m)show_message("2") sound_stop(m) sound_delete(m)} itd.. czasem nie odtwarza w ogóle dzwięku 7 i 5, w podobnych kodach tez niektóre dzwieki nie są odtwarzane a niektóre dłuższe pod koniec odtwarzania lekko sie przytną.. Gdy sound_delete zamieniłem na sound_discard problem jakby wstępnie zniknął z czego bierze się ten błąd ? czy sound_delete() potrzebuje jakiegos czasu by opróżnić pamięć?
×
×
  • Dodaj nową pozycję...